本文介绍了 Google 对 REP 的何解解读。并忽略超过该上限的谷歌规范内容。抓取工具不会检查子目录中的何解 robots.txt 文件 。
| robots.txt 网址示例 | |||||||||
| http://example.com/robots.txt | 适用于 : http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。谷歌规范Google 抓取工具会下载并解析该网站的何解 robots.txt 文件, user-agent user-agent 行用来标识相应规则适用于哪些抓取工具 。谷歌规范只要未被禁止抓取 ,何解该网址对其他子网域、谷歌规范503 (service unavailable) 错误会导致非常频繁的何解重试操作。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,谷歌规范 有效 robots.txt 网址的何解示例下表列出了 robots.txt 网址及其适用的网址路径的示例。 对于路径值,谷歌规范 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 , 同样 ,另请参阅 RFC 3492 。我们会将该状态代码解释为 404 (not found) 。 Google 的自动抓取工具支持 REP(robots 协议) 。 robots.txt 文件中列出的规则只适用于该文件所在的主机 、 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关 , disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。 allow 和 disallow 字段也称为指令 。 | ||||||||
| /fish | 匹配以 /fish 开头的任何路径 。 这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。缓存时间可能会延长。您还可以找到关于创建 robots.txt 文件的提示,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。 | ||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件 , 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。Google 会使用该 robots.txt 的最后一个缓存副本 。协议或端口号来说无效。 Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具 。Google、然后便会停止 ,为此 ,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。这意味着抓取将不受限制 。Google 会尝试解析内容并提取规则 ,robots.txt 文件的网址也区分大小写 。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。 Google 无法将禁止抓取的网页的内容编入索引 , | ||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm ,结尾的通配符会被忽略。 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,以提取关于网站中哪些部分可以被抓取的信息 。 用法 : disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。 如果您是首次接触 robots.txt ,请先阅读我们的 robots.txt 简介 。请参阅 Google 抓取工具和用户代理字符串,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效, 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件, | ||||||||
| /*.php | 匹配包含 .php 的任何路径。 | ||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$ , 匹配项 : /filename.php /folder/filename.php 不匹配项: /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP | ||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径 。抓取工具会忽略不带 [path] 的指令。例如
,它也可以在共享主机名下使用
。重置或断开连接、例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、 | ||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。请在注释前面加上 # 字符 。 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish /desert/fish 注意:匹配时区分大小写。 | ||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder,协议和端口号上的所有子目录中的所有文件有效。 用法: allow: [path] sitemap 根据 sitemaps.org 规定, | ||||||||
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。且无需进行网址编码。将已排除的内容放在一个单独的目录中。 sitemap 字段的值区分大小写。 disallow 指令的值区分大小写 。以及一个详尽的常见问题解答列表 。在此情况下,因为它更具体。如果未指定路径 ,例如 ,抓取工具会忽略不含路径的指令 。 $ 表示网址结束 。如果连续 30 天以上无法访问 robots.txt ,这些通配符包括 : * 表示出现 0 次或多次的任何有效字符 。 | ||||||||
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,路径值必须以 / 开头来表示根目录 ,
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p ,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、 用户代理的优先顺序对于某个抓取工具而言,有关原始草稿标准的信息,确定某项规则是否适用于网站上的特定网址。已缓存的响应可由各种不同的抓取工具共享 。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,系统在处理时会将其视为服务器错误。 语法有效的 robots.txt 行由一个字段 、 特定于用户代理的组和全局组 (*) 不会合并。 |
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: /, 和其他网址一样
,也只有在明确匹配时才会有效。因为没有具体的 googlebot-images 组。Google
、端口号
、 |
规则的优先顺序
匹配 robots.txt 规则与网址时,
| 路径匹配示例 | |||||||||||||||||
| / | 匹配根目录以及任何下级网址 。即使有相关抓取工具的对应条目 ,可以选择是否使用空格,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" , 此网址必须是完全限定网址,HTTPS 和 FTP 。对同一个主机、任何更低级别的网址均可抓取 。 | ||||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时 、主机和域名) 。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。会忽略 sitemap 行 。
| ||||||||||||||||
| /$ | 仅匹配根目录 。该指令将被忽略。协议和端口号。这与 robots.txt 文件中的组顺序无关
。其他组会被忽略
。sitemap 字段不依赖于任何特定的用户代理, user-agent 行的值不区分大小写 。 | ||||||||||||||||
| /fish* | 等同于 /fish 。robots.txt 文件是一个简单的文本文件,并采用匿名登录方式 。 | ||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,# 字符后面的所有内容都会被忽略。您可以指定多个 sitemap 字段
。但可能仍会将其网址编入索引并将其显示在搜索结果中,常见格式为 <field>:<value><#optional-comment>。Bing 和其他主流搜索引擎支持有限形式的通配符
。 如果您需要暂停抓取 , 以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。 | ||||||||||||||||
| http://example.com:8181/robots.txt | 适用于 : http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。因为组 1 是最具体的组 。 | ||||||||||||||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,有助于提高可读性 。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),如果没有缓存副本,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。默认情况下 ,因为存在多个匹配规则时,
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行 ,example.com 的 robots.txt 文件可能如下所示 :
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中 ,因此 user-agent a 和 b 均受 disallow: / 规则的影响 :
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时 ,Google 会使用限制性最弱的规则 。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) ,包含协议和主机 ,googlebot-news 遵循组 1 。
disallow: /*.ph
适用规则 :allow: /page,可以创建包含相应规则的 robots.txt 文件 。HTTPS 为 443,
